Webhook Delivery Latency - Partial Degradation

Incident Report for apaleo

Resolved

Webhook delivery performance has returned to normal, and the vast majority of events are now processing on time. We consider this incident resolved, but our team will continue to monitor the system to ensure sustained stability.
Posted Aug 22, 2025 - 08:51 UTC

Monitoring

Our team has implemented mitigations and webhook delivery latency has decreased significantly. Most events are now processing close to normal speed, though we are continuing to monitor performance closely to ensure full stability
Posted Aug 21, 2025 - 09:55 UTC

Investigating

We are currently investigating an issue causing intermittent delays in webhook delivery. Some customers may experience slower-than-normal processing times or degraded performance when receiving webhook events.
Posted Aug 20, 2025 - 09:12 UTC
This incident affected: Webhooks.