Investigating performance issue on rate plan pricing

Incident Report for apaleo

Resolved

An update was deployed that has improved the performance.
Posted Jul 20, 2026 - 13:09 UTC

Update

We are continuing to investigate this issue.
Posted Jul 20, 2026 - 13:05 UTC

Investigating

We are currently investigating a performance issue that may cause the rate plan pricing screen to become slow or unresponsive for some properties. We will share an update as soon as we know more.
Posted Jul 20, 2026 - 11:21 UTC
This incident affected: UI.