Degraded performance of payments processing
Incident Report for apaleo
Resolved
This incident has been resolved.
Posted Mar 16, 2022 - 08:42 UTC
Update
We are continuing to investigate this issue.
Posted Mar 16, 2022 - 07:32 UTC
Investigating
We are currently investigating this issue.
Posted Mar 16, 2022 - 07:32 UTC
This incident affected: API and Payment.