Incident on 2023-08-12 17:00 UTC

Incident Report for apaleo

Resolved

This incident has been resolved.
Posted Aug 12, 2023 - 18:31 UTC

Update

Our payment processing infrastructure is running behind which is causing inaccuracies in the folio payments. No data or payments have been lost and the system should be caught up shortly.
Posted Aug 12, 2023 - 17:04 UTC

Investigating

We are currently investigating this issue.
Posted Aug 12, 2023 - 17:03 UTC
This incident affected: Payment.