Folio payments are facing delays in processing

Incident Report for apaleo

Resolved

We continue to monitor
Posted Oct 23, 2025 - 14:41 UTC

Monitoring

An intermittent load spike caused delays and some elevated errors. The system is now operating normally. We will monitor the situation.
Posted Oct 23, 2025 - 14:38 UTC

Update

We are continuing to investigate this issue.
Posted Oct 23, 2025 - 14:04 UTC

Investigating

Folio payments are facing delays in processing due to an internal service degradation. We are investigating on the issue.
Posted Oct 23, 2025 - 11:30 UTC
This incident affected: Payment.